If someone visits a directory on your hosting account that does not have an index file (index.html, index.php, index.htm, etc.), they will either see a list of files in that directory or receive a banned warning. This prevents them from accessing the directory’s contents. You can grant or deny permission to view the contents of the folder. You can also choose the type of information that appears on the page if you display the contents.

Folder indexing generally disabled on our servers to improve the security of our customers’ accounts.

Indexing Models:- When someone accesses a folder with standard indexing, only the file names displayed, with no other information about the files in that location. To use this type of indexing, place the following lines in the desired folders. htaccess file:

1.Options +Indexes

2.IndexOptions –FancyIndexing

Creative Indexing:- Fancy indexing displays the files as well as additional information about them, such as the date the file was last modified, its size, and description. To use this type of indexing, add the following two lines to the destination folders. htaccess file:

1.Options +Indexes

2.IndexOptions +FancyIndexing

No Indexing:- If you do not want a folder on your account without an index file to display a list of files contained within it, you can disable the indexing functionality. To accomplish this, add the following line to the. htaccess file in the required directory:

Options –Indexes

As a result, if someone tries to open the folder in their browser, they will get a 403 Forbidden message.

You can change the Apache directory listing style in this way. If you continue to have problems with the protocol outlined above, please contact the bodHOST Team for constructive assistance 24×7.

Popular Posts You May Read

Explore more hosting insights, tips and industry updates.

Apache fails to start due to: Failed to configure encrypted (?) private key

In this tutorial, we’ll explain how Apache fails to start due to: When Apache is…

Reset Plesk’s Admin Password on Windows Server

Reset Plesk’s admin password on Windows Server: Log in to windows server via RDP as…

How To Force Your Site Visitors to Use Shared SSL Connection

From time to time, our technical support department is asked how to direct website visitors…