Reset Plesk’s admin password on Windows Server: Log in to windows server via RDP as an administrator, then open the command prompt and run the following commands :> C:\Program Files\SWsoft\Plesk\admin\bin\plesksrvclient.exe

execute this file and you prompted to enter in a new password for your “admin” Plesk user. You can then

log into the Plesk interface again and use it as normal.

Popular Posts You May Read

Explore more hosting insights, tips and industry updates.

How To Perform A Full Website Backup?

Performing a backup within your cPanel is a simple and straightforward process. Normally we recommend…

How to Use WHM to Create MySQL Profiles

This tutorial outlines the process of creating MySQL profiles via WHM. MySQL profiles govern the…

If Access is denied to a website when opening a Browser –

Use the IP address instead of the Domain name, if you are able to do…